Ruby On Rails 4に関する最新の質問

0
答える

Rails4.1.16から4.2.0にアップグレードする際のPostgresの問題

Rails 4.2 ARは、明らかにpgのバージョン0.15に依存しています。それを使用してアプリをビルドしようとすると、「gemネイティブ拡張機能のビルドに失敗しました」というメッセージが表示されます。問題は「PQconnectionUsedPassword()のチェック」にあります。この点を乗り越えるために、Postgresのインストールをアップグレードしました。これは、その機能をサポートしていなかったためです。そこで、Postgresのマルチバージョンエディションをインストールし、データを10.0サーバーに移行してから、再試行しました。同じ結果。どうすればこれを修正できますか?

activerecord ruby on rails 4 postgresql bundler ruby on rails

0
答える

Railsで遅延ジョブが完了した後、ビュー側で応答としてデータを取得する方法はありますか?

1つのCSVファイルをインポートしようとしています。そのタスクをDelayedJobに渡して実行し、DelayedJobがCSVを読み取って1つのオブジェクトにデータを格納する1つのメソッドを呼び出します。次に、そのオブジェクトをビューの応答として取得するにはどうすればよいですか。側。これに取り組む方法はありますか?

ruby on rails ruby on rails 4

1
答える

Rails4.1から4.2へのアップグレードffi/rb-inotifyの問題

Rails4.1アプリをRails4.2に移行します。最後に、rb-inotifyをバージョン0.9.1に固定してビルドしました(0.10.1はビルドされないため、Ruby >=2.2が必要です。実際には、0.9.1から0.9.10までのどのバージョンでも同じ結果が得られますが、0.9 .1は4.1)でロードされたバージョンでした。 「railsc」を実行すると、次のようになります。

ruby on rails ruby on rails 4

2
答え

Rubyは、ファイルを1行ずつ読み取り、gsubを使用して特定の部分を取り出したいと考えています。

URLを含むテキストファイルまたはcsvファイルを1行ずつ読み取るコードを記述していますが、各URLのIDを出力してテキストファイルに出力または保存したいのですが、使用するとエラーが発生します。ループの前にループする行ごとに印刷することができます。誰かがこれで私を助けることができますか? 以下は私のコードサンプルです。

ruby on rails 3 rubygems ruby on rails 4 ruby ruby on rails 5

0
答える

Railsウィジェットベースのデザイン

ホームページのウィジェットベースのデザインを簡単に実行できるRailsgemなどがあるかどうかを知りたいと思いました。予算のWebアプリをプロジェクトとして作成していて、見たくない情報を移動および削除する機能は、私たちが望んでいることの1つです。私たちが探しているものを説明するために写真を追加しました。

ruby on rails rubygems ruby on rails 5 ruby on rails 3 ruby on rails 4

ホットタグ

© 2021   KonnichiwaSekai.Com